Калькулятор CIDR / подсетей

Расчёт подсетей IPv4 и IPv6, типы адресов и разбиение на подсети

Ввод

IPv4 или IPv6 с /префиксом, маской подсети или без них.

Определено:
IPv4
Длина префикса
Рассчитано: 10.0.0.0/16.

Только расчёт: адреса не пингуются, не разрешаются и не проверяются на выделение.

Параметры

До 20 бит длиннее (1 048 576 подсетей).

Добавляет двоичную запись адреса IPv4, масок, сети и широковещательного адреса.

Результаты

ПолеЗначениеКопировать
Адрес10.0.0.0
Сеть (CIDR)10.0.0.0/16
Длина префикса/1616 бит хоста
Маска подсети255.255.0.0
Обратная маска0.0.255.255
Адрес сети10.0.0.0
Широковещательный адрес10.0.255.255
Первый адрес10.0.0.0
Последний адрес10.0.255.255
Диапазон доступных хостов10.0.0.1 – 10.0.255.254
Всего адресов65 5362^16
Доступных хостов65 534без адреса сети и широковещательного
Тип адреса
Частный
Частный10.0.0.0/8 · RFC 1918
Зона обратного DNS0.10.in-addr.arpa
Целое число167772160
Шестнадцатеричный вид0x0a000000

Подсети

16 подсетей /20

1
10.0.0.0/20
Доступный диапазон: 10.0.0.1 – 10.0.15.254 · Широковещательный 10.0.15.255
2
10.0.16.0/20
Доступный диапазон: 10.0.16.1 – 10.0.31.254 · Широковещательный 10.0.31.255
3
10.0.32.0/20
Доступный диапазон: 10.0.32.1 – 10.0.47.254 · Широковещательный 10.0.47.255
4
10.0.48.0/20
Доступный диапазон: 10.0.48.1 – 10.0.63.254 · Широковещательный 10.0.63.255
5
10.0.64.0/20
Доступный диапазон: 10.0.64.1 – 10.0.79.254 · Широковещательный 10.0.79.255
6
10.0.80.0/20
Доступный диапазон: 10.0.80.1 – 10.0.95.254 · Широковещательный 10.0.95.255
7
10.0.96.0/20
Доступный диапазон: 10.0.96.1 – 10.0.111.254 · Широковещательный 10.0.111.255
8
10.0.112.0/20
Доступный диапазон: 10.0.112.1 – 10.0.127.254 · Широковещательный 10.0.127.255
9
10.0.128.0/20
Доступный диапазон: 10.0.128.1 – 10.0.143.254 · Широковещательный 10.0.143.255
10
10.0.144.0/20
Доступный диапазон: 10.0.144.1 – 10.0.159.254 · Широковещательный 10.0.159.255
11
10.0.160.0/20
Доступный диапазон: 10.0.160.1 – 10.0.175.254 · Широковещательный 10.0.175.255
12
10.0.176.0/20
Доступный диапазон: 10.0.176.1 – 10.0.191.254 · Широковещательный 10.0.191.255
13
10.0.192.0/20
Доступный диапазон: 10.0.192.1 – 10.0.207.254 · Широковещательный 10.0.207.255
14
10.0.208.0/20
Доступный диапазон: 10.0.208.1 – 10.0.223.254 · Широковещательный 10.0.223.255

Рассчитано: 10.0.0.0/16.

Что рассчитывается

Введите адрес IPv4 или IPv6 с длиной префикса (10.0.0.5/20), с маской подсети в точечной записи (10.0.0.5 255.255.240.0) или без них. Калькулятор показывает сеть, маску подсети и обратную (wildcard) маску, широковещательный адрес, первый и последний адрес, диапазон доступных хостов, общее и доступное количество, тип адреса по реестрам IANA адресов специального назначения и зону обратного DNS. Все вычисления выполняются с точными большими целыми числами, поэтому /0 в IPv6 или IPv4 рассчитывается так же точно, как /24.

Как считаются доступные хосты

Для IPv4 от /0 до /30 исключаются адрес сети и широковещательный адрес. В /31 оба адреса доступны для каналов точка-точка (RFC 3021), широковещательного адреса нет; /32 — маршрут к одному хосту. В IPv6 нет широковещания, поэтому учитываются все адреса префикса, а /127 отмечается как канал точка-точка (RFC 6164).

Разбиение префикса

Выберите более длинный префикс в поле «Разбить на», чтобы получить список подсетей, например 10.0.0.0/16 на шестнадцать сетей /20. Разбиение ограничено 20 дополнительными битами (1 048 576 подсетей); список показывает первые 4096 строк и всегда указывает реальное общее число, а «Копировать подсети» и «Скачать CSV» включают до 65 536 подсетей.

Правила ввода и ограничения

IPv4 должен состоять из четырёх десятичных октетов: ведущие нули, сокращённые формы вроде 10.1 и шестнадцатеричная запись отклоняются, потому что разные системы читают их по-разному. IPv6 принимается в текстовых формах RFC 4291, включая :: и встроенный IPv4 в конце; результаты выводятся в канонической форме RFC 5952. Идентификаторы зоны (%eth0) не принимаются. Инструмент только считает: ничего не пингуется, не разрешается и не сверяется с реестром выделений, а введённые адреса не сохраняются.

CodingTool официально запущен на

Launched on StartupBaseCodingTool.dev - Free, Fast & Easy Developer Tools in One Place | Product HuntCodingTool - Featured on Startup FameFazier badgeListed on Turbo0Featured on Twelve ToolsFeatured on Findly.toolsLaunchpadly Startup DirectoryCodingTool.dev — Featured on Smol Launch